Bryant 340AAV, High Limit Tripping, Error Code 33

Hi,

My house was built in 2006.

I had my furnace cleaned a couple weeks ago by a local HVAC company. This past Thursday, I turned the heat on for the first time since they did the cleaning and the high limit switch started tripping. My Nest thermostat alerted me to the fact that the furnace wasn’t running for longer than 15 minutes. So, I crank up the heat and go to the furnace, sure enough, trips after 4-6 minutes of continuous heating with error code 33.

The filters in there are the $3 kind from Home Depot and not limiting air flow.

After some troubleshooting and consultations over the weekend, we determine the most likely culprit is the high limit switch. Well, this morning the high limit switch was totally shot. The furnace was continuously throwing error code 33 and blowing cold air – the fan wouldn’t shut off.

Here’s what we did

We 1. replaced the high limit switch and 2. turned the fan speed to the medium-high setting (from medium-low). The new high limit switch tripped at about 14 minutes after we nearly thought we solved the problem. Had some more consultations, and found out the top part of the furnace was much to hot to the touch, much hotter than the bottom half.

Called people that cleaned the furnace. They asked, "do you know if you have a secondary heat exchanger? It’s pretty rare, only about 10% of furnaces have them and if you have it, we didn’t clean it." Me, "no clue, let me look up the model number and see." Sure enough, my Bryant 340AAV has a secondary heat exchanger.

They’re coming back out tomorrow to clean it.

Meanwhile, after 10-16 minute of running, it’s still tripping and throwing error code 33. If I pull the filter (no filter) it runs for 30-40 minutes easy. Put the air filter in, 10-16 minutes, trip.

How likely is it that they dirtied up the secondary heat exchange while cleaning everything else and that’s causing the error code 33? The secondary heat exchange has never been cleaned, so, if everything was cleaned and the secondary heat exchanger wasn’t, how likely is it that a dirty secondary exchanger can’t keep up air flow of the newly cleaned everything else? What else could be the problem?

Just not sure what to do about this anymore, and could really use your advice.

M

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s